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Abstract 
A polymer cholesteric liquid crystal (PCLC) flake suspended in a host fluid 

of differing dielectric constant will reorient due to the difference between the dielectric 
constants of the flake and the fluid host. A basic equation of motion for flake 
reorientation has been developed, but it is necessary to investigate the details of the 
electrical torque acting on the flake. The electrical torque is driven by Maxwell-Wagner 
polarization, and computer modeling using COMSOL's software, FEMLAB, allows this 

phenomenon to be investigated. Modeling results have confirmed the experimental 
phenomenon of flake reorientation based on the examination of the electric field, the 
electric potential distribution, and the surface charge density. 

Background 
As their name suggests, liquid crystals have 

properties of both crystals and liquids. In crystals the 
molecules have fixed positions, arranged geometrically. 
In liquids, orientation and position are random and 
disorganized. In liquid crystals, the molecules are 
partially organized. In nematic liquid crystals, for 
instance, all the molecules point the same way, but aren't 
arranged in a neat box pattern, or any other pattern, for 
that matter. In cholesteric liquid crystals, the molecules 
orient in a helical fashion (Fig 1) '. This helical pattern of 
orientation gives cholesteric liquid crystals some of their 
unique properties, such as selective reflection of circularly 

polarized light2. Polymer liquid crystals are polymers that 
include liquid crystal molecules either as part of the 
backbone or side chains of the polymer. 

Polymer cholesteric liquid crystal (PCLC) 
flakes are formed by applying a thin PCLC film to a (from Ref. 1) 

silicon wafer. Liquid nitrogen is then applied to cause a 
p-p-p. - 



sudden temperature change. Differential thermal expansion of the PCLC film and silicon 
wafer causes the PCLC film to fracture into flakes3. This generally leads to irregularly 
shaped flakes. However, it is possible to etch out patterns through soft lithography, to 
allow flakes of a desired shape to be formed2. 

The orientation of polymer cholesteric liquid crystal (PCLC) flakes in a 
slightly conducting host fluid can be controlled by electric fields. An AC field causes the 
flakes to rotate about their longest axis, so that their second longest axis aligns parallel to 
the electric field. When the field is turned off, the flakes gradually return to an 
orientation such that both the longest and the second longest axes are parallel to the 
substrates2. 

Due to this property, PCLC flakes show great promise in the display field. 
Normal liquid crystal displays (LCDs) operate by sandwiching a nematic liquid crystal 
fluid between two crossed polarizing filters. The orientation of the liquid crystal 
molecules controls the polarization of light, either permitting or preventing the light from 
passing through both polarizing filters4. The orientation of the liquid crystal molecules 
can be controlled by the application of an electric field. Using polarizers places a strict 
limit on the amount of light that can be reflected back or transmitted, no better than 50% 
of the incident light3. PCLC flake based displays could offer greater reflection, and thus 
brightness. PCLC flakes also offer the ability to use circularly polarized light, which is 
useful in some applications. The other major advantage of PCLC flakes lies in 
microencapsulation. Microencapsulation involves enclosing small droplets of flake- 
containing host fluid inside a sheet of rubber-like material. Advantages include the 
ability to make flexible displays, increased ease of creating pixilated devices as compared 
to non-microencapsulated designs, and the possibility of making bi-stable displays, 
displays that only need power to change the image they show, not to maintain the image3. 

The driving mechanism behind the flake reorientation is Maxwell-Wagner 
polarization, a build up of surface charge at the interface between two different 
dielectrics2. Opposite charges are built up on the top and bottom of the flake, as shown in 
Fig. 2. The applied electric field will exert a torque upon the flake in Fig.2 if and only if 
the flake has some slight tilt bias with respect to the substrates. Both PCLC flakes and 
the host fluid are dielectric materials. Each molecule of a dielectric has a slightly 
asymmetric charge distribution. Normally, the molecules are oriented randomly, so no 
charge develops. However, in an electric field, the molecules reorient so that the 
positive side of the molecule points in the direction of the electric field. There is no net 
change in charge, as no charges leave the flake. However, at each end of the dielectric 
object, a surface charge is generated where the charged ends of the molecules line up5. 
The charge is opposite at opposite ends of the flake, generating a dipole moment. 



Figure 2: Charge distribution around flake due 

to Maxwell-Wagner interfacial polarization. 
The red rectangles represent the electrodes, 
while the arrow indicates the electric field 
direction. The flake will only reorient if it is no1 
perfectly parallel to the substrates (i.e, if there 

in the flake long axis) 

The dipole moment can be acted upon by the electric field surrounding the flake, 

generating a torque which causes the flake to rotate. The direction of the torque can be 
visualized by placing the base of the electric field vector at the tip of the dipole moment 
vector. 

Equations that predict how long it will take for the flake to align with its 

second longest axis parallel to the electric field have been derived from first principles 
using an ellipsoidal shape flake, instead of the more rectangular cross-section of most 
flakes, for simplicity's sake3. There are two problems: it is not well understood what the 
equations mean in the physical sense (i.e. what was actually happening to cause the 

rotation), and the equations are incomplete, as their predictions don't match perfectly 
with the experimental results. The object of this project was to model the electric fields 
and potentials in and around the flake to try to come to a better understanding of the 
physical process involved, and hopefully, determine what is missing from the derived 
equations. 

Parameters used to describe configuration of the cell 
PCLC flakes are generally suspended in a host fluid between two glass 

plates coated with indium-tin oxide (ITO). Almost all modeling conducted in the course 

of this project used 5*10-' S/m (Siemenslmeter) and 69 as the conductivity and dielectric 
permittivity of the host fluid, respectively. 1 * S/m and 2.89 were used as the 

conductivity and relative permittivity of the flake. These values were used for all 
FEMLAB model-derived figures in this report. All figures also use a cell gap, or 



distance between the glass substrates, of 50 ym. The flakes are modeled as ellipses, with 

a major axis of 40 ym , representing the second longest axis of the flake, and a model 

minor axis of 6 ym, representing the flake's shortest axis. In all models except ion 

transport models, a voltage of 10 V was applied to the bottom plate, this representing the 
peak voltage in AC models. In ion transport models, the applied peak voltage was only 

0.03 V. The upper plate was grounded in all modeling. 

FEMLAB modeling 
In order to explore flake reorientation, FEMLAB was used to generate 

computer models of the flakelhost fluid capacitor-like system under AC and DC fields. 
FEMLAB is a multi-physics simulation program made by COMSOL. It is based on 
partial differential equations (PDE), which can either be written by the user, or selected 
from a series of provided application modes. The provided application modes consist of 
a set of PDEs designed to model certain circumstances, such as static electric fields. All 
that is then required is to define the geometry of the objects to be modeled and insert 
proper values for the variables representing the properties of the materials, such as 
conductivity. For this investigation, only the built-in application modes were used. 
FEMLAB is called a multi-physics simulation because of its ability to couple multiple 
application modes together by linking variables. It is possible to use the output variables 
of one model to define the input variables of a second, and even to use the output of the 
second model to define the input of the first model. This feature allows even rather 
complex systems to be modeled without having to directly define custom PDEs. The 
version of FEMLAB used for this report (v3.0.0.228), can't model rotating flakes. All 
the geometric domains of the model, which are used to define the shape and position of 
the flake, must be static. 

Initially, a series of models of flake systems in a DC field were generated, 
with the flake at varying angles with respect to the horizontal. The flakes were modeled 
as ellipsoidal, despite actually being more rectangular, because the theoretical work of 
Ref. 3 treated them as ellipsoids. These early models showed that the electric potential 
dropped much more rapidly across the flake than across the host fluid (in this case, 
propylene carbonate). This led to interesting electric field distributions in which the 

electric fields outside the flake follow the contour of the flake's external surface fairly 
closely. The most interesting result was the direction of the electric field inside the flake 
itself. For a wide range of angles, the internal electric field of the flake was nearly 
perpendicular to the second longest axis of the flake, and this field direction was 

maintained when the flake was rotated 45 degrees with respect to the electrode plates. 
When the flake was rotated 30 degrees from the plane of the electrodes, the internal 



electric field in the flake is at an angle that is roughly 75 degrees to the normal of the 
flake's second longest axis (Fig 3). Dielectric materials in an electric field align 
themselves so as to set up an electric field opposing the applied field. The molecules of 
the dielectric rotate, or the electric distribution changes, so that the molecules align with 
the applied electric field. Because the molecules merely realign there is no net charge in 
the material or any charge in the body of the dielectric material. However, surface 

charges do build up at the edges of the material. In the flakes, this would generate a 
dipole moment parallel to the internal electric field upon which the electric field could 
work, causing the flakes to move. The torque applied is equal to the cross-product of the 
induced dipole moment vector and the electric field vector. If the dipole moment were 
along the second longest axis, as originally believed, the torque exerted by the modeled 

electric field would force the flake towards a vertical orientation. However, the modeled 
internal electric field of the flake would lead to a dipole moment fairly perpendicular to 
the second longest axis, which would cause a restoring torque on the flake, forcing it 
back towards the horizontal. This predicted rotation is in the opposite direction of the 
observed rotation, presenting a major problem. 

Next, the flake system was modeled in an AC field, using the Quasi-statics, 
small in-plane current application mode of FEMLAB's Electromagnetics module. This 
application mode uses a time harmonic solver, which assumes that the model undergoes 
periodic, rather than transient changes. 

After FEMLAB solves the model, it is possible to change the field's phase 
during post processing. Solutions to this sort of model were very similar to that of the DC 
models (Fig 4). Two things are of interest, however. The AC models confirmed that the 
dipole moment would switch directions with the field, although not necessarily without 
some lag. Therefore, the flake would always rotate in the same direction, regardless of 
the actual direction of the applied electric field. This behavior reflects the quadratic 
dependence upon the electric field seen in the theoretical equations, which implies that 
rotation is independent of the sign of the applied electric field. 

Although FEMLAB is not currently capable of modeling rotating flakes, it 
is possible to get around this limitation in certain cases in which the solution at a given 
angle could be solved independently of the solution at an earlier angle. Because the 
electric field changes so much faster than the flake rotates, it was assumed that a series of 
static flake models at different angles would be a suitable approximation of a rotating 

flake. MATLAB was used to generate the series of models needed, generating a static 
model of a flake at the angle it would achieve at a certain point in time. In each model, 
the magnitude of the applied electric field was determined by what the phase of the AC 
field would be at the point in time the model represents. An equation was derived from 



the previously done theoretical work to predict how much the flake would rotate in a set 

period of time. This new position was used to create a FEMLAB model. The plot of this 
model was then saved as a unique, separate image file, and then this cycle was repeated. 
The program automatically ended once the flake reached a preset angle. A separate 
program was then written to cycle through the generated images, displaying each in turn, 

to function as an animation. 
It is believed that the motion of ions within the host fluid and the flake plays 

an important role in explaining flake rotation, including, possibly, the reason that the 
theoretical calculations were off by a significant factor in calculating the rotation time. 
Therefore modeling of ion movement was undertaken. For this, a multiphysics model 
had to be created by coupling the Electrokinetics application mode of the Chemical 
Engineering module to the Electrostatics generalized application mode of the 
Electromagnetics module. The Quasi-statics, small in-plane currents application mode 
wasn't used, because a time dependent, rather than time harmonic model was needed. 

Initial attempts at coupling these two application modes via voltage were unsuccessful, 
apparently because the values used for the applied potential were excessively high. 
Before this problem was resolved, a series of models were then made using only the 
Electrokinetics application mode, which allowed for different diffusion properties 
between the flake and host fluid, but could only apply a uniform electric field. 

After the problems coupling the Electrokinetics and the Electrostatics 

generalized application modes were resolved, models were created that could simulate 
ion movement in the electric fields set up by the flake-capacitor system. Two nearly 
identical species of ions were used in most models, the first with a charge of one positive 
elementary charge, the other with one negative elementary charge. Later, the 
concentration of ions was linked to the space charge density in the electrostatics model. 
However, to retain comprehensible modeling, the space charge density so calculated had 
to be multiplied by 1x10-~, so it probably was inaccurate. One major problem was never 

resolved. There is very little information available on the type, mobility, and 
concentration of the ion species involved, so out of necessity much of the modeling relied 
on reasonable guesses and various idealizations to get a model in which it was easy to see 
what was happening. From these it was easy to see the charge build up on each plate. As 
would be expected, a positive charge built up on the negative plate, and vice versa. At 
every polarity switch of the applied electric field, the collected ions would be forced off 
the plate in a layer. Where not obstructed, this layer of ions would soon disperse and 
neutralize. Ions built up on both sides of the flake. On the side of the flake nearest to the 
negative electrode, a negative charge would build up, and vice versa (Fig 5). As time 

progressed, these ion concentrations would move towards the center of the flake 



All the modeling that has been done so far has indicated that the flake would 

not align with its second longest axis parallel to the electric field, but rather rotate so that 
the second longest axis is parallel to the substrates. There is one possible answer, 

however. The equation for the dipole moment of one axis is 

When E, is less than E ~ ,  which is the case in the examined system, the dipole 

term is negative. This would mean that the dipole moment is actually anti-parallel to the 
electric field, rather than parallel to the electric field, as had been previously assumed. 

47C 
pi = a i a  jak 

3 EOi 

pi = induced dipole moment along flake axis i 

a; = length of flake axis i 
E,, = relative dielectric constant of host fluid 

1 q, = relative dielectric constant of PCLC flake 
EOi = electric field applied along flake axis i 

Figure 3: A flake in a DC field, rotated with its 

long axis approximately at a 30 degree angle 

from the substrates. 

surface: ~ l ~ ~ ~ ~ i ~  potential 
Contour: Electric potential 
Arrows: Electric field 



Now, taking the cross product of the induced dipole moment and the exterior electric 
field would result in a torque forcing the flake towards a vertical orientation with its 
second longest axis parallel to the applied electric field. 

This argument also makes sense physically. In the previous discussion of 
the dipole moment, the host fluid's contribution to the surface charge at the host fluid- 
flake interface was neglected. The host fluid has a higher dielectric constant than the 
flake does, which means that the dielectric particles of the host fluid align more closely to 
the applied electric field than those of the flakes. The host fluid would therefore generate 
a stronger surface charge in a given applied electric field than the flake would. Because 

Figure 4: A flake in an AC field of 50 hertz. The Surface: Electric potential i 

flake is rotated 30 degrees above the horizontal, Contour: Elecwic potential 

j and the field is at 0 degrees in phase. 1 Arrows: Electric field 



Figure 5: The surface plot is the difference between 
the concentration of the positive and negative ion 

species. The mobility of both ion species in the host 
fluid is set as 1 x 10-lo (m/s)/(N/mol), while the 

diffusivity constant is 1 x 10-lo *2476 kgl(m2*s). The 
bottom electrode in the Figure is negatively charged. 

Surface: c l-c2 
Contour: Electric potential 
Arrows: Electric field 

of the geometry of the situation, the surface charges created by the host fluid and the 
flake would be of opposite polarity, so if the surface charge generated by the host fluid, 
instead of the flake, dominate, than the induced dipole moment would be anti-parallel to 
the electric field. 

Confirming this in FEMLAB is difficult. FEMLAB does have a variable 
for surface charge, but unfortunately, this is for the free charge, not the bound surface 
charge. However, FEMLAB allows a custom equation to be input that will govern the 
boundary plot. The equation below can be used to generate a surface charge plot.6 



E p  --&h 1 p, = surface charge density 
p,7 = Eo [ T ] ~ n o r m  1 & = dielectric constant 

LE,,~.. = component of electric field perpendicular to the surface 
-- -- -- -. - . -- 

In the FEMLAB model, the electric field term of the above equation is the dot product of 
the simulated electric field and the unit vector perpendicular to the flake at a given point. 
This yields the magnitude of the electric field perpendicular to the flake surface. 

So far, this has only been properly done on spherical objects and horizontal 
ellipsoidal flakes (Fig 6), but the surface charge distribution calculated indicates a dipole 
moment anti-parallel to the electric field. The torque can be found by taking the cross- 
product of the external (to the flake) electric field, and the dipole moment, when it is 
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taken to be antiparallel to the internal electric field of the flake. The predicted torque 
would then force the flake towards the vertical, with the second longest axis orienting 

parallel to the applied electric field. This agrees with experimental observation, as well 
as the predictions of theory 

Summarv 
PCLC flakes, when subjected to an electric field while in a host fluid of 

greater dielectric constant, develop an induced dipole moment antiparallel to the internal 
electric field of the flake. This has been indicated by theory, empirical reasoning, and 
FEMLAB modeling, and agrees well with experimental results. Further work on fully 
integrating surface charge into the FEMLAB models, expanding the modeling of ion 
mobility, using FEMLAB to calculate torques, and modeling true rotating geometries 
when FEMLAB becomes capable of doing so is still needed. 



Appendix 1 
FEMLAB modeling 

2D AC Capacitor With Flake 
The following are instructions for building a capacitor inside of which is a flake 

of polymer liquid crystal in FEMLAB energized by an AC source. The capacitor is 
assumed to consist of a pair of plates, a dielectric, and the flake. The capacitor is 
assumed to be rectangular in shape, and only a cross section will be modeled. The plates 
and the dielectric of the capacitor are assumed to have the same width and to be 
assembled in sandwich fashion, i.e. with nothing wrapping around the end of the 
dielectric. Furthermore, the plates are idealized, in that they are assumed to have no eddy 
currents or unevenness in potential. 

To load FENILAB, log onto a server from the terminal, maple if it isn't busy, 
otherwise lime might be the best choice, using xrlogin servername. From there, type 

femlab to start the program. FEMLAB will launch the model navigator, which has four 
tabs along the top, New, Model Library, User Models, and Settings. Clicking on the 
Model Library tab displays a listing of folders containing FEMLAB's demos. The User 
Models tab displays all the FEMLAB files in the folder which is set as the library root. It 
is not possible to go up folders in this view. Any files you wish to access have to be 
either in this folder or in folders within the library root. However, it is quite easy to 
change the library root by pressing the library root button when the User Models tab is 
active. To start a new model, click on the New tab. 

When the New tab is selected, FEMLAB displays a file tree showing all of its 
application modes, grouped by applications. Immediately above the file tree is a drop- 
down menu to select geometry type, ID, 2D, 3D, ID axis symmetric, and 2D axis 
symmetric. 2D is the default, and is what should be used for this application. In the file 
tree, double click on the Electromagnetics module folder. If you were modeling a DC 
capacitor, you would want to use the Electrostatics mode, if the conductivity can be 
ignored, or the Electrostatics, generalized, if conductivity is to be included, inside the 
Statics folder. However, to model an AC capacitor, select the Quasi-Statics folder, then 
the Small In-Plane Currents application mode. Then click on the OK button, or you 
could just double click on the Small In-Plane Currents icon in the file tree. 



This launches FEMLAB's Graphical User Interface (GUI). The large white area 
in the bottom right corner is the geometry modeling area. Before starting to model, open 
the Options>Visualization/Selection Options menu and turning off face highlighting, or if 
you're working in 3D, both face rendering and face highlighting. This greatly increases 
the program's speed, although it can occasionally make selecting certain geometries 
difficult. Select Options>Axis/Grid Settings. This is where the size of the axes and 
the spacing of the grid is set. Set the axes so that they are a bit larger than the total size 
of the capacitor. It's probably best to set the axis so that the origin is in the center. That 
will make everything much easier. Next, go to Draw>Specify ObjecbRectangle. This is 
where you can enter values to create a rectangle in the geometry space, as opposed to 
having to draw it. Set the dimensions equal to the dielectric of the capacitor. (FEMLAB 
will change the dimensions of the axis so that they will fit into the geometry space 
properly and without distortion.) Set its base to center, which means that the coordinates 
specified below will be at the rectangle's center, not its corner. Leave the coordinates at 
(0,0), again just for ease. Then create the flake, either using yet another rectangle or an 
ellipse, it doesn't really matter. Remember, if you are making an ellipse, that you are 
specifying the flakes semi-axis. 

Now it is time to specify the physical characteristics of the model. Open 
Physics>Subdomain Settings. This sets the characteristics of the insides of the 
geometries. There should be two subdomains, corresponding to the dielectric, the first 
subdomain, and the flake, the second. Open the dielectric and the flake subdomains, and 
set the proper dielectric constant and conductivity. Next open Physics>Boundary 
Settings. This is where you set the properties of the boundaries between geometries. 
Notice that there is a checkbox labeled interior boundaries. This will display any 
boundaries that are between two geometries, as opposed to boundaries with essentially 
empty space. Leave this empty, as only the external boundaries need to be changed. If 
the flake is ellipsoidal, boundaries 1 and 4 should correspond to the sides of the 
dielectric. These should be set to the electric insulation boundary setting. Boundary two 
should be the bottom of the dielectric. Set this to the Electric potential boundary setting, 



and set the voltage to the maximum voltage you want the AC field to reach. Leave 
boundary 3 set to ground. 

Next, select Mesh>Initialize Mesh, or press the button with a single triangle on it. 
This displays the mesh that will be used to calculate the solution. If it looks too coarse, 
either select Mesh>Refine Mesh, or press the button with four gray triangles arranged as 
one larger triangle, and repeat until the mesh looks fine enough. Remember that the finer 
the mesh, the longer it will take to calculate the solution. 

Finally, select Solve>Solve Problem, or press the button with the equals sign on 
it, and wait for FEMLAB to finish solving the problem. When it does so, you should see 
a surface graph (the coloring in of the surface) that plots the electric potential at any point 
within the geometries. To display different properties, or different or more graphs, select 
Postproscessing>Plot Parameters, or press the button with the amorphous colored blob 
and the question mark on it. Here you can select multiple different plots at once, 
displaying many different properties, or even the same properties. To change the view, 
you can open Options>Zoom and select a command from there, or there are 4 buttons on 
the toolbar. The + and - magnifying glasses are pretty standard. The magnifying glass 
with the rectangle on it allows you to select an area of the plot to view by drag-selecting 
it with the mouse. The magnifying glass with the four arrows is zoom extents, which 
zooms out until you can see all the geometries you created. Plotting the same value on 
the surface and contour plots works quite nicely, as the contour plot makes details of the 
surface plot much easier to see. Remember that you aren't limited to the default 
expressions to plot. You can input your own expressions in the plot expression box, to 
make the plot show whatever you want. You can use the various generated variables, 
such as Ex-qvw for the x-component of the electric field in a quasi-statics, small in- 
plane current model, as well as the variables x and y to make an expression position 
dependent. Also, under the general t.ab, there is a box in which you can place a logical 
expression to limit which elements are displayed. I generally used this to place spatial 
limits on the plots, although you could probably use any valid expression. 

Finally, if you want to animate something that FEMLAB itself can handle, such 
as an AC field or moving ions, but not rotating flakes, you can use the Animate mode of 
postprocessing. Unfortunately, this doesn't work on Linux systems, at least not well. It 
works much better to create and solve the model in FEMLAB. Go to a PC that has the 
FEMLAB viewer installed ( ask Dr. Kosc or another experienced user about this) and 
then use the animate selection of the FENILAB viewer's postprocessing mode menu. 
Although you can't make changes to the physics of the model here, you can chose 
whatever plots you wish, and the animation works much better. 



3D Capacitor Modeling 
3D capacitor modeling is almost identical to 2D modeling, there is just one more 

dimension to specify in the model. There are, however, two important things to 
remember, boundary suppression and solve preconditioner. 

When modeling in 3D, one major problem is that the outside geometries hide 
those inside. During modeling itself, just setting transparency in Options>Visualization 
Options to about 0.5 will work [even transparent geometries can make post-processing 
difficult to look at, especially if using a boundary plotting mode]. The way around this is 
through boundary suppression. After having set the physics of the model, go to 
Options>Suppression>Boundary. Then in the pop-up menu select the boundaries that lie 
between the camera and the flake. Then press apply, and leave. The boundaries selected 
will disappear, no longer impairing vision. 

In 3D Quasi-Statics, Small Currents, FEMLAB defaults the solver 
preconditioner to Algebraic Multigrid. Unfortunately, this doesn't work. Select 
Solver>Solver Parameters, and the under preconditioner select SSOR. Then just solve 
normally. 



Appendix 2 
Model/Program inventory 

FEMLAB Models by folder 

In general, the dielectric constant of the dielectric is 69, and its conductivity 
is 5e-5. The dielectric constant of the flake is 2.89, and its conductivity is le-12. 
FEMLAB 

Ion transport useful # 

DC models of ion transport in a uniform DC electric field. The potential is 
set directly proportional to the y-coordinate. The flake is modeled with a different 
diffusivity and mobility than the dielectric. Electrically, however, it is identical. These 
are not multiphysics models. 

Ion transport AC no multiphvsics 
-Identical to Ion transport useful # except that the potential is time dependent. This is 
accomplished through the subdomain physics menu. 

Ion movement multi-model # degrees 
-These are a series of models similar to Ion transport AC no Multiphysics. They are all 
identical except for the angle at which the flake is from the horizontal. 

Ion Transport, 2 species 
-Similar to Ion transport useful# except it models the transport of 2 different types of 
ions with opposite charge, but identical mobilities. 

Encapsulated flake 1, # degrees 
-DC models of the electric properties of an encapsulated flake, using the Electrostatics, 
generalized application mode. 

Encapsulatedflake conductive wall layer, #degrees 
-Similar to encapsulatedflake 1, # degrees, but uses a different boundary condition on 
the capsule. Instead of the continuity boundary condition, the thin conductive layer 



boundary mode is used instead. 

Flake capacitor 1, # degrees 
-DC models of a simple flake-capacitor system. 

Bound.. . 
-These are assorted electrostatics models, that use an expression for the bound surface 
charge to try to properly map the surface charge of a flake. 

AC modeling 
These are early attempts to model flake systems. The models in the Standardized Models 
folder are probably of more use. 

splitJake-1 # degrees 

-AC modeling of a rectangular flake with a conducting layer of material running through 
the middle of the flake. 

splitJake-oval-imperfect dip 

-Similar to splitJake-1 #degrees, but with an oval rather than rectangular flake. At 
each corner of the flake there is a small triangular sub-domain that was the result of a 
simplified modeling process. They are set to have the same properties as the dielectric 
and can be ignored. 

Standardized Models 
These are a series of models, all using the same design parameters for easy comparison. 
The dielectric is 100 um thick, and the flake is 20 um long and 6 um thick. The applied 
voltage is 10 V, applied to the bottom boundary of the dielectric field. This is an AC 
model, so this voltage varies from 10 V to -10 V, depending on the phase. Frequency can 
be controlled in the physics-scalar variables menu. 

Elip Flake # degrees 
-models of the electric properties of flakes in 2D. Does not include ion transport. 

Rect Flake # degrees 

-Similar to Elip Flake #degrees, but with rectangular flake. 



Rotated-Capacitor-4.5-Degrees 

-Similar to Elip Flake # o f  degrees, but with a longer flake, and with capacitor not the 
flake, rotated out of the horizontal. Useful for examining vector values on the surface 
relative to the flake instead of the capacitor. 

Elip Flake sigma comparison 
-2 parallel models of flake systems. The dielectrics are shorter, and have differing 
conductivities. The flakes are longer than standard. 

3 0  Elip Flake 0 degrees 

3 0  Rect Flake 0 degrees 

-3D versions of these models. In order to actually see the insides, it is necessary to 
suppress the outside boundaries. 

Ion Transport 

All of these models are multiphysics combinations of the Electrostatics, generalized, and 
the Electrokinetics, transient analysis, application modes. As a shorthand, I use dif for 
diffusivity, mob for ion mobility, and c(0) for the initial concentration. All the models 
have equal concentrations of positive and negative ions. Sub 1 is the subdomain 
representing the dielectric, and sub 2 is the subdomain representing the flake. For those 
models including surface charge coupling, charge is the fudge factor included in the 
coupling. 

Ion Transport I degrees # 

-Early multiphysiscs models of ion transport in a flake-capacitor system. Only one 
species of ion is modeled, and the application modes are only coupled via voltage. 

Vmax = .03 V 
sub 1 dif = 1e-10*2476 mob = le-10 c(0) = 2 

sub 2 dif = le-12 mob = 1e-1212476 c(0) = 0 

Ion transport 2 species #degrees space charge coupled # herz 

-Ion transport with two ion species. The two species are identical except for charge. 
Species one has a single positive elementary charge, while species two has a single 
negative elementary charge. The application modes are coupled by both voltage and 

surface charge. 
Vmax = .03 Charge = le-6 



sub 1 dif = le-10*2476 mob = le-10 c(0) = .5 
sub 2 dif = le-12 mob = le-1212476 c(0) = 0 

Ion Transport 2 species # degrees higher voltage 
-Similar to Ion transport 2 species # degrees space charge coupled # herz but with 
different subdomain and voltage settings 

Vmax = 2.5 frq = 10 charge = le-6 
sub 1 dif = l e  

Ion Transport/Movie Files 
This subfolder of the Ion transport holds movie files generated by FEMLAB 
postproscesing from the Ion Transport femlab file of the same name. The one exception 

is Elec-only-30-degrees.avi, which is an animation of a static flake in an AC field. 

MATLAB programs by folder 

Flake 

Flake-2D_angularqosition#.m 
-Uses theoretical equations to drive a rotating flake model. The theory determines the 
angle of the flake, which is used in a FEMLAB model. At each new angle, a new 
FEMLAB model is generated. 

Flake-Chargeqlotter#.m 
-Uses theoretical equations to plot charge on a flake's axis, assuming point charges at the 
ends of the axis. This is done for a series of different angles of the second longest axis 
above the horizontal. Version # 2 also plots predicted torques at the angles. 

Flake-Phase-Siml .m 
-Changes the phase of applied voltage to a stationary 2D flake using the FEMLAB quasi- 
static model. 

Ion-transport-sim-1 .m 
-Animates a single discrete ion within a capacitor without a flake. 

rotation-time-chart-writer.m 

-displays the time needed for a flake to rotate about 90 degrees for varying conductivities 
and dielectric constants of the dielectric part of the capacitor. 



time-to-rotate-angle-1 .m 
-Displays the time needed to rotate about 0 degrees above the horizontal to various 
angles, as determined by a one dimensional array. 

torque-check-l.m, torque-check-2.m, torque-sim1.m 
-These programs attempt to use the FEMLAB cemtorque function to calculate the torque 
on the flake. These were not very successful. For the energy expression required by the 
cemtorque function torque-check-1 uses Weav, while torque-check-2 uses V, the 
electric potential. Version 2 of the torque-check program is an improvement, but it is 
still highly inaccurate when compared to the theoretical torques. 

2D Simulation Images 
This is a collection of programs used to generate a series of images, and then display 
them in series, to show a rotating flake. This appears to be an early folder, with many of 
its images removed, so programs in other folders would probably be more useful. One 

general rule, though, is that anything called a writer is used to generate and save a series 
of images derived from FEMLAB models, while anything labeled a player is meant to 
play back a specific series of images. This is dependent upon the name of the image, so 
changing image names would cause errors. 

Flake animation 
This is a similar folder to 2D Simulation Images, but is later, and with a complete set of 
images. The different mode numbers refer to different values plotted on the surface plot 
by separate programs. Mode one plots electric potential, mode two plots the x-component 
of the total current density, and mode three plots the y-component of the total current 

density. Flake-2D-mode-1-writer.m is more or less fully commented. The rest aren't. 

Flake-2D-mode-#-writer. m 

-Generates a series of images using the plot parameters given by the mode number. It 
generates images for three different frequencies, 10 Hz, 70Hz, and 150 Hz. 

Flake-2D-mode-#_frq-#glayer. m 
-Plays the images created by one of the writer programs for the specified plot mode and 
frequency. 



Animation~enerator.m 
-This program runs the three Flake-2D-mode-#-writer.m programs as subroutines, to 
allow them all to be run as a single program overnight. 

Flake animation1Alternate Style 
Very similar to the programs in Flake animation, except that the conductivity is plotted 
on the surface plot, and electric potential is plotted on the contours. 

Flake-2D-Alternate-writer.m 
-Creates images of rotating flakes according to the plotting parameters above. 

Flake-2Dfrq-#jlayer. m 
-plays the images at the specified frequency generated by Flake-2D-alternate-writer.m. 

Ion Transport 
These files contains models that were generated at a time when we were not completely 
certain how to use the Chemical Engineering module to model ion transport. These 
models trace a small number (no more than 24) of discrete ions. The movement is 
governed by an electrophoresis equation, using FEMLAB models to run this equation. 
The function postinterp() was used to get the value of the electric fields from the 
FEMLAB models for use in the MATLAB program. Given the presence of the 
FEMLAB chemical engineering module ion transport models, the files in this folder are 
not of great use. 

Ion Transport Movie 

Flake-ion-transport-writer.m 
This is a very crude method of modeling a rotating flake with ion transport. This model 
works by making a series of FEMLAB ion transport models, each with a flake at a 
different angle, and then solving them from an initial condition with homogeneous ion 
distributions up to a point in time determined by the angle of the flake. It stiches these 
images together to generate a movie. This is probably highly inaccurate. As currently 
set up, it takes around 30 hours to run, and the output is very suspect. 

Flake-ion-transport-writer.m 

-This program runs the series of images generated by Flake-ion-transport-writer.m 



Phase Change Images 
This folder contains programs to animate a stationary flake in an AC field. This is better 
done using the FEMLAB viewer Animation post-processing mode. 

Quasi Static flake simulator 

The files in these folders animate a rotating flake using parameters and plots typical of 
the later style, i.e. longer flakes and potential plotted both on the surface and on the 
contour plots. 

Flake-quasi-writer-#.m 
-Generates 1 image every 11/10 of a field cycle to keep play and generation time 
reasonable. 

Flake-quasi-reader-I. m 
-Plays images generated by Flake-quasi-writer-#.m. 

Flake-quasi-moviejen-#. m 
-More or less unsuccessful attempts to get MATLAB to generate avi files. 
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